Missing library? Issue when compiling a new FreeRTOS project

No really. I couldn’t make it work. Recently tried a feature in CCS that is used to add files into the project. Was adding the files one by one and compiling to see the next file request. But at the end, got another error message, as shown in the attached pic


It looks like configASSERT is not defined in the FreeRTOSConfig.h.
These are two common options, depending on the application:

/* Use the FreeRTOS assert function.
 * Increases code size and flash usage considerably. */
#define configASSERT ( x )     if( ( x ) == 0 ) vAssertCalled( __FILE__, __LINE__ )
/* Disable interrupts and sit in an infinite loop.
 * Useful when a debugger can be attached, and it also consumes minimal flash. */
#define configASSERT ( x )     if( ( x ) == 0 ) { taskDISABLE_INTERRUPTS(); for( ;; ); }

Is it possible for you to share your project?

Yes, will do that soon.

Okay, it’s not possible to upload attachments, so here are the pics of the latest error message

The first two images show the type of error at the last compilation. The original project without FreeRTOS, had each header and source file added at the rate of one file per compilation and the next added file was selected according the compiler request in the previous compilation. After a number of files, the error observed is the last one. All these messages appear in each configAssert() macro in the task.h file, but from the message is not clear about what is needed to get rid of this error messages. The last pic shows the files of FreeRTOS that were added up to this point. These files were added with the feature in the IDE to add files to the project as seen below.

The macros didn’t presented any errors in the previous attempts, so the cause is elsewhere. I think some file(s) are missing but is not clear from the error message.

In this particular project it was actually defined, as follows:

You should be able to upload now. Alternatively, you can put your code in a git repo and share link.

I think there was some progress. These last errors were fixed by setting the priority parameters in the FreeRTOSConfig.h file (1).
I added the rest of the files in the FreeRTOS package and the previous xTaskCreate error disappeared, though it was replaced by something else, which is the current error (2). Looking in the map file, can be seen that there are a bunch of undefined objects (3). The first two seem to be related to settings, so I am focusing in the last four for now, and trying to figure out the cause. Attached are the pics of these scenarios. If I can I will upload the entire project. This is not commercial, only an educational project.

Add the following to your FreeRTOSConfig.h file -


Wow, that solved the issue. Finally can start focusing in the application instead. Thanks a lot.