LPC2888 port

widita wrote on Tuesday, October 28, 2008:

I tried to convert the demo project “ARM7_LPC2129_Keil”, and it seems there is something wrong with the portmacro.h, it can’t be compiled…

here is the compilation error messages:

Build target ‘LPC2888’
assembling Startup.s…
compiling main.c…
…\…\Source\include\…\…\Source\portable\Keil\ARM7\portmacro.h(112): error:  #52: expected a macro parameter name

portmacro.h line 112:
    __asm{ LDR        LR, [LR, #+60]    }; /* Restore the return address. */ \

And here is the IDE-Version of my Keil UV3

    µVision3 V3.50
    Copyright (c) Keil Elektronik GmbH / Keil Software, Inc. 1995 - 2007

    Tool Version Numbers:
    Toolchain Path:    C:\Keil\ARM\BIN30
    C Compiler:         ARMCC.Exe       V3.0.0.951
    Assembler:          ARMASM.Exe       V3.0.0.951
    Linker/Locator:     ARMLINK.Exe       V3.0.0.951
    Librarian:          ARMAR.Exe       V3.0.0.951
    Hex Converter:      FROMELF.Exe       V3.0.0.951
    CPU DLL:            SARM.DLL       V3.04
    Dialog DLL:         DARMP.DLL       V1.13
    Target DLL:         BIN\UL2ARM.DLL       V1.26
    Dialog DLL:         TARMP.DLL       V1.11f

My question is, are we using different compiler? because it seems that those errors is shown because of the compiler is treating the code differently?
and indeed, when I tried to compile using the original project file (rtosdemo_ARM.Uv2), it said about cannot find the compiler.

What should I do to compile these project files?

Thanks in advance,


rtel wrote on Wednesday, October 29, 2008:

If you are using FreeRTOS.org V5.1.0 then the project is setup to use the Keil/RVDS compiler.  If you are using a previous version then the project is setup to use the old and now obsolete Keil/Keil compiler.


widita wrote on Thursday, October 30, 2008:

I am not aware that v5.10 has been released,

I will port my project right away and keep you updated.