LPC2368 demo execution problem

martinpb wrote on Wednesday, April 18, 2007:

Hi all,

I have tried the LPC2368 demo for the MCB2300 board, but it doesn’t seem to run.

my board is MCB2300 ver. 3.0.
And i am using the Rowley crossworks 1.6 IDE

I have compiled the demo from within rowley crossworks, but unfortunately i dont have a debugger available to me right now. I program the board using the Flash magic programming tool.

I did although notice that ARM/Thumb settings for each file in the project wasn’t set, so i did that myself before i compiled the project. So normal c files are compiled in thumb mode and isr’s are compiled in arm mode. Other than that, the options seems to be correct.

I have tried though to debug through the Eclipse, i have the arm-usb-ocd debugger from Olimex, using openocd as GDB server. But i never reach the main function. Instead i end up her:

0x000002ec <reset_wait>:   b 0x2ec <reset_wait>

does anyone have an idea, as to what might be wrong ?


nobody wrote on Wednesday, April 18, 2007:

The ARM/THUMB settings are set as far as I can see.  The project settings are configured for COMMON, ARM, THUMB, etc. individually.  If you look in the right place you get the setting.  This is a Crossworks feature that is really nice once you get the hang of it but not otherwise obvious.

martinpb wrote on Thursday, April 19, 2007:

Ok i found the problem.

In the startup code Philips_lpc230x_startup.s, STARTUP_FROM_RESET wasn’t defined.
So i just added #define STARTUP_FROM_RESET 1. And now it is running.

But shouldn’t this be defined elsewhere ?


martinpb wrote on Thursday, April 19, 2007:

Encountered another problem with the demo :slight_smile:

When I open a http connection to the device, the device stops responding.
Some of the page is shown. Has this demo been tested before release ?

The demo files are unmodified, just compiled with crossworks IDE 1.6.

nobody wrote on Thursday, April 19, 2007:

Ok that makes perfect sense.  Start up from reset is defined in the project as a preprocessor constant.  The “debug” builds don’t have startup from reset defined.  The Release builds do.  Therefore when you are not starting the code through the debugger you need to be using a release build or make the definition yourself.

embeddedc wrote on Thursday, April 19, 2007:

Works ok for me (I just replied to your other post too but it seemed to have lost my login cookie).  I only changed the IP address, nothing else.

Does the rest of the demo work for you after the network stops responding?  Do the LED’s still flash?

martinpb wrote on Thursday, April 19, 2007:

Hi embeddedc,

everything stops. It seems that the application crashes and raises an abort interrupt.
Unfortunately it isn’t too happy about me debugging the application, through eclipse using the olimex arm.usb-ocd, either. So i will wait till i
get the cross connect debugger back, before i continue :slight_smile:

I have previously been working with a sam7x and crossworks, where the boot from flash bit was set. So i wasn’t aware of the fact that there is that difference between debug and release mode.

Thank you all for your replies.