rbutler wrote on Friday, September 21, 2007:


I used the ARM7_LPC2106_GCC demo as my basis for a project using an LPC2129.  I changed the linker file to match the available ram/flash that the 2129 has available, got rid of most of the tasks except the comport test and the led test and verified it worked as expected (4.4.0 but then later moved to 4.5.0).

I modified the serial port part of the demo to support both UART0 and UART1 on the 2129 and verified all worked well by putting an LED toggle debug in the ISR for UART1 and running the comtest demo on UART0, all worked well, LED toggles on reception of data on UART1 and the comtest tasks executed as they always have.

I then commented out the comtest and LED demo parts and inserted my own tasks and this is where things got kind of weird.  My tasks don’t seem to run.  I did some debugging by printing to UART0 and LED toggles (don’t have enough ram unfortunately in the 2129 to debug in RAM using eclipse and openocd I don’t think) and I can see that both of my tasks (UART0 tx and rx tasks) are getting added to the scheduler list.  I also put a debug printout and led toggle after the call in main.c to start the scheduler to see if that was failing and dropping me back into main, and it is not.  So it appears that the tasks are getting added, the scheduler started and the tasks are never getting run.

I commented out all the code in my task functions so it’s just an LED toggle (first item) then a for loop that does nothing and I still get no action from the tasks, with nothing inside the task functions, I wouldn’t think it could be a stack overflow issue.

I then went and added an LED toggle to the idle task in the FreeRTOS part of the sources and that is not causing a LED state change either, so it doesn’t appear that the idle task is even running.

However, during all of this, if I do connect anything to uart0 or 1, interrupts are getting processed still as the led’s flash as data comes in.  If I re-enable the tasks from comtest.c, all the uart0 stuff works as expected so I don’t think it has anything to do with the serial modifications.  I am not running any uart1 tasks at this time.

I used the comtest.c example (in the Minimal part) as the base for my tasks file and how I’m starting them looks identical.

Does anyone have any suggestions of what this sounds like is happening or what other "in code" tests I could do to try to narrow it down?


rtel wrote on Friday, September 21, 2007:

Hmm, strange.  It seems you have gone through a logical sequence to track the problem down.  One thing though - I have been trying Eclipse and OpenOCD recently, and have been using break points even when running from flash.  Can you not do this?  (see the Eclipse/LPC2368 demo on the FreeRTOS.org site).