LPC1768 RedSuite Demo will not compile

wlcolman wrote on Wednesday, November 24, 2010:

RDB1768 demo board.
Red Suite 3 v3.5.6 Build 227.
FreeRTOS V6.1.0.

I tried to build the demo using the following steps:
1)  Downloaded FreeRTOS
2)  Unzipped FreeRTOS
3)  Located the directory: Demo/CORTEX_LPC1768_GCC_RedSuite
4)  The batch file named, “CreateProjectDirectoryStructure.bat” was missing
5)  Copied the batch file from a previous version of FreeRTOS
6)  Ran the batch file
7)  Imported the project using File->Import->Existing Projects Into Workspace
8)  Errors and Warnings from syscalls, notably: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘_sbrk_r’
referencing function:  caddr_t _sbrk_r (struct _reent *r, int incr)


rtel wrote on Wednesday, November 24, 2010:

I just tried a clean V6.1.0 installation and the batch file is there - but can confirm getting the same errors as you.  Exclude the file syscalls.c from the build (right click on it in the project explorer window and select “exclude from build” in the pop up window) then the project will build ok.