iPerf project working on 10.4.1, not working on 202212.01

Hi, I have a iPerf project working completely fine in 10.4.1, but once I change the FreeRTOS 202212.01, although it can compile successfully, there is no ping reply or iPerf connection can be establish. I would want to attach the 2 configs, but is not permitted because I am a new user. Any place should I look at? Is there any API/ config change between these two versions?

Hello @choonzone,

AWS Moderators, operators, please allow @choonzone to attach files :slight_smile:

It looks like you upgraded the FreeRTOS kernel. Did you FreeRTOS+TCP at the same time?

I think that your problem is not caused by a “wrong version” of the FreeRTOS kernel.

It is very difficult to guess what the cause is. I would like to see your network-related code and indeed, your FreeRTOSIPConfig.h

The iperf 3.0 server worked well in any +TCP release. We always use it as one of the quality tests.

I have forgotten to add I am using FreeRTOS and FreeRTOS Plus bundle. The project works in 10.4.1 but not the latest 202212.01

Hi @choonzone, could you see if you could upload now? Let me know if you still can’t, I’ll try to fix it.

freertosDemoIPerf-working-direct.zip (455.3 KB)

Hi @ydhuang , I can upload now. Thanks for the help.

Hi @htibosch , I have uploaded the project. Appreciate if you could take a look. :slight_smile:

@htibosch I have tried various mix and match of FreeRTOS kernel and TCP version. I found out that it is not related to TCP version, as TCP from 202212.01 is working with 10.4.1 kernel. So the problem must come from certain kernel, I continue to test like this and conclude that the first kernel breaks the project is 10.5.0. Do you know which part of 10.5.0 kernel potentially breaks the code?

First thank you very much for your effort getting into so much detail.

I looked at my own +TCP projects: the newest kernel that I tested with was 10.5.1

I haven’t tested with the 10.5.0 kernel yet, so I will do so now (on an STM32F747).

I do not see any problem with the FreeRTOS kernel 10.5.0, the behaviour is just the same as 10.5.1

In my experience, the kernel and the +TCP library are very independent: +TCP works with any kernel, starting with the older V8.1, the first version that had event groups.

Running iperf is quite a complex task. Can you do simpler things like ping your device. And can you show a PCAP in two situations:

  1. when things go right
  2. when things fail

A PCAP can be created with e.g. WireShark. You can zip the resulting file and attach it to your post.