Integration of the demo project in HCS12P64

karima7 wrote on Sunday, March 20, 2016:

Hello everyone,

I find in the page of FreeRTOS exactly in the page source code contribution, functional demo folder, for the family HCS12P, here is the link in which I found the project file.

After compilation, I make the choice of target, and then when I integrate the code into the microcontroller using CodeWarrior, no error message is displayed, and I can Run the program in the card that contain the microcontroller or stop it, but the card that I use always keep the old code, and does not take into account the new code, I don’t know if it’s a problem of memory or other problem.

Thanks in advance.


rtel wrote on Sunday, March 20, 2016:

Can I paraphrase this to “I cannot program the microcontroller flash”? If so, that would seem to be a tools issue rather than a FreeRTOS issue.

karima7 wrote on Sunday, March 20, 2016:

The file that I downloaded is a compressed file, if I compile the project from the zipped file no error detected, but I can not make changes to the code, even if I put in the archive changes made.
several files appear in the project tree, but in reality they are not in the zipped folder.

When I unzip the downloaded file, and I compile dialogs informs me that I have to delete files because it automatically generates after deleting these files I compile. But unfortunately that generate 34 errors, most of them indicate that the files do not exist.

I tried to integrate the missing files from the FreeRTOS download folder, but it involves other errors since FreeRTOSConfig.h file used in the project is reduced.

I wonder if anyone has worked with this demo project contributed? and if anyone has got this type of problem?
Thanks in advance.


khalid1992 wrote on Monday, March 28, 2016: