FreeRtos Porting with Nabto

sakthikappu wrote on Monday, July 31, 2017:


I am trying to port the FreeRtos with Nabto for windows using visual studio 2017 or 2015 , provided freertos +nabto sdk and freertos sdk from the freertos website in the below link

After downloading we have performed our application modified from the program demo in this path


our application is provided in the below

When we compile the above demo by adding our application into it using visual studio , it is successfully builded when we run it it is showing up this error

Exception thrown at 0x00000000 in RTOSDemo.exe: 0xC0000005: Access violation executing location 0x00000000.

If there is a handler for this exception, the program may be safely continued.

May i please to know what it is the error about as i am new using visual studio , is there any ways to debug this issue

Please help us to resolve this



rtel wrote on Monday, July 31, 2017:

Access violation at address 0 means something tried to access address
0x00000000 (NULL). In this case something tried to execute something at
that address, which I would guess means (perhaps) you tried to execute
an uninitialised function pointer.

This is a C coding/debugging question though, not a FreeRTOS question.