FreeRTOS on energymicro GiantGeko (sourcery)

valeriobardelli wrote on Tuesday, June 19, 2012:

I’m trying to port FreeRTOS on energymicro GiantGeko (CortexM3) with codesourcery cross-compiler. I’m able to compile and run a demo application, but the task that I create it seems that doesn’t start.
When I try to debug it seems that vPortStartFirstTask in port.c (an assembler routine) hangs forever, but the task routine is never reached.
My starting point was, but I tryed also with the last version of FreeRTOS and I have a similar problem (in prvPortStartFirstTask routine in port.c).

Any idea about this problem?

Any help is greatly appreciated!

Regards, Valerio

rtel wrote on Tuesday, June 19, 2012:

it seems that vPortStartFirstTask in port.c (an assembler routine) hangs forever

This function calls SVC, which generates an interrupt/exception.  Have you populated the vector table with the FreeRTOS interrupt handlers?  Or alternatively if you are using CMSIS files, mapped the FreeRTOS interrupt handlers to the CMSIS handler names in FreeRTOSConifg.h as per post 2 here:

Did you also try the official demo (without the tickless modification?)


valeriobardelli wrote on Wednesday, June 20, 2012:

Hi Richard,

many thanks for your response! :wink:

Yes, I tried with official demo (as I explain in my first post), but I port it from IAR (I think the only compiler supported, at the moment for energymicro) to codesourcery because our OEM customer don’t want to buy a licence. If there is a FreeRTOS port for codesourcery (for energymicro) could be very usefull! :wink:

The problem it seems to be soved!!!!

I have to change the code in startup_efm32gg.s (I compile this file instead of the modified startup_efm32_cs3.s in the project because I have GiantGeko and not Geko, this is my orrible mistake! -.- ).

But, I think the best and elegant solution, is to add in my FreeRTOSConfig.h this few lines:

#define vPortSVCHandler SVC_Handler
#define xPortPendSVHandler PendSV_Handler
#define vPortSVCHandler SVC_Handler
#define xPortSysTickHandler SysTick_Handler
Now it works! I can also debug with eclipse and JLink! Great! I can investigate now about EM2 energy mode...
Thanks a lot for your precious, professional and very quick support!
Regards, Valerio