fprintf trouble on Atmel 1284p?

kd5uwl wrote on Thursday, October 22, 2009:

When doing this:

    fprintf_P(stderr, PSTR("CORE: %dF"), (int)ddsp->coretemp);

It runs as expected for several iterations, then quits (other tasks halt as well).  Unusal thing is that it stops after printing the number, but before printing the "F" (which happens to stand for Fahrenheit).

I’m working now to see how to look at stack utilization, but since this MCU has lots of memory, I’ve tried ridiculously large stack settings in FreeRTOSConfig.h with no noticeable difference in behavior.

I’ve seen mention of the minimalistic printf-stdargs.c but there is not one for the ATmega 8 bit devices.  I’ve tried to adapt one, but no luck so far.

Anyone had similar issues?

kd5uwl wrote on Thursday, October 22, 2009:

Sorry about the &quot and &gt in the code.  Those are the double quote and greater than symbol, respectively.

kd5uwl wrote on Thursday, October 22, 2009:

I’m sorry, I may have posted here prematurely.  It’s starting to look like a problem with my LCD implementation, and nothing regarding printf at all.

kd5uwl wrote on Friday, October 23, 2009:

Sorry to bother you fine gentlemen, but I have not solved this.  Any pointers appreciated!