Errors in HCSC12 Codewarrior Banked and Small memory demo projects

srikanth56 wrote on Monday, May 04, 2015:

Hi!

I have downloaded FreeRTOS V8.2.1. I want to use the RTOS for Freescale MC9S12G240. I was trying to build the demo codes available for S12 family of microcontrollers i.e., MC9S12C32 and MC9S12DP256B with Code Warrior IDE . But it failed. I got plenty of errors though I have followed the exact same steps as mentioned in the demo page for the microcontroller.
Are there are any Processor Expert settings that need to be changed?
Please let me know what needs to be done in order to eliminate the errors and ensure proper working of the RTOS.

rtel wrote on Monday, May 04, 2015:

Unfortunately you don’t say what the errors are - but as that is a rather old demo I suspect they will be a result of changes in the tools (compiler, IDE, etc.) since the demo was created. I am aware of people using that port, but it might be that they created their build project themselves, rather than taking the project in the download.

Regards.

srikanth56 wrote on Tuesday, May 05, 2015:

I am attaching the errors for the banked memory demo. Please let me know what are the changes that need to be made in order to run the demo in the present version of Code Warrior.

srikanth56 wrote on Tuesday, May 05, 2015:

Please let me know which version of Code Warrior supports the demo provided.

rtel wrote on Tuesday, May 05, 2015:

I’m afraid I can’t/won’t open Word documents from the Internet. Can you
post the errors into the forum directly?

I’m not sure which version of Code Warrior was used, but it was an old
one, I may be able to tell you when I have access to my other computer,
but that won’t be until the weekend.

Regards.

srikanth56 wrote on Wednesday, May 06, 2015:

There 66 errors in the banked memory demo. I am posting just a few of those.

Errors:
Error : C52: Error in command line '-BfaGapLimitBits0 -Cf -D_HCS12 -DHCS12_CODE_WARRIOR -D__NO_FLOAT__ -I. -I…\Source\portable\CodeWarrior\HCS12
-I…\Common\include -I…\Source\include -Mb -Os -Ou -Of -Oi -OiLib=a -OnB=abl -OnCstVar -OnPMNC -Or -TD4LD4LLD4 -WmsgSd1420
-WmsgSd4001 -WmsgSd4002 -WmsgSd4301 -WmsgSd5703 -WmsgSd5904 -WmsgSd5905 -WmsgSd5909 -WmsgSd5917 -WmsgSd12053 -WmsgSd12056 -env"GENPATH=D:\FreeRTOSV8.2.1\FreeRTOS\Demo\HCS12_CodeWarrior_banked;D:\FreeRTOSV8.2.1\FreeRTOS\Demo\HCS12_CodeWarrior_banked\bin;D:\FreeRTOSV8.2.1\FreeRTOS\Demo\HCS12_CodeWarrior_banked\prm;D:\FreeRTOSV8.2.1\FreeRTOS\Demo\HCS12_CodeWarrior_banked\cmd;D:\FreeRTOSV8.2.1\FreeRTOS\Demo\HCS12_CodeWarrior_banked\Sources;C:\Program
Files (x86)\Freescale\CWS12v5.1\lib\HC12c\lib;C:\Program Files (x86)\Freescale\CWS12v5.1\lib\HC12c\src;D:\FreeRTOSV8.2.1\FreeRTOS\Demo\HCS12_CodeWarrior_banked\Code;D:\FreeRTOSV8.2.1\FreeRTOS\Demo\HCS12_CodeWarrior_banked\doc;C:\Program
Files (x86)\Freescale\CWS12v5.1\lib\hc12c\include;D:\FreeRTOSV8.2.1\FreeRTOS\Demo\HCS12_CodeWarrior_banked\ParTest;D:\FreeRTOSV8.2.1\FreeRTOS\Demo\HCS12_CodeWarrior_banked\serial;D:\FreeRTOSV8.2.1\FreeRTOS\Source;D:\FreeRTOSV8.2.1\FreeRTOS\Source\portable\MemMang;D:\FreeRTOSV8.2.1\FreeRTOS\Demo\Common\Minimal;D:\FreeRTOSV8.2.1\FreeRTOS\Source\portable\CodeWarrior\HCS12;D:\FreeRTOSV8.2.1\FreeRTOS\Demo\HCS12_CodeWarrior_banked\CODE;D:\FreeRTOSV8.2.1\FreeRTOS\Demo\HCS12_CodeWarrior_banked\DOC;C:\Program
Files (x86)\Freescale\CWS12v5.1\lib\HC12c\include" -env"LIBPATH=C:\Program Files (x86)\Freescale\CWS12v5.1\lib\HC12c\include"
-env"OBJPATH=D:\FreeRTOSV8.2.1\FreeRTOS\Demo\HCS12_CodeWarrior_banked\bin" -env"TEXTPATH=D:\FreeRTOSV8.2.1\FreeRTOS\Demo\HCS12_CodeWarrior_banked\bin"
-objn=“D:\FreeRTOSV8.2.1\FreeRTOS\Demo\HCS12_CodeWarrior_banked\RTOSDemo_Data\P&E_ICD\ObjectCode\Cpu.C.o” ’

Error : Error in command line!

Error : C4202: Invalid pragma OPTION, Invalid Options

IO_Map.h line 40

Error : Compile failed

edwards3 wrote on Wednesday, May 06, 2015:

If the command line is wrong then the compiler has changed either completely or substantially. Were you able to open the project right away or did you have to go through some kind of update wizard in order to get it open? Have you looked in the manual to see what the command line needs?

srikanth56 wrote on Thursday, May 07, 2015:

I was able to open the project right away. I’ve referred to the manual but I didn’t find a solution.