Eclipse + MingW - No output console

I am new to FreeRTOS and Eclipse. To start, I just wanted to build the main_blinky in Eclipse + MingW. I set the constant mainCREATE_SIMPLE_BLINKY_DEMO_ONLY to 1 and build the program. The program builds and creates the exe. When I run the program, I do not see any console output. I am not sure how should I see the output in Eclipse IDE. Can anyone give me some input on this?

Separately, when I run RTOSDemo.exe from windows explorer, the application opens up a command prompt window and displays the message"Trace output saved to trace.dump". The windows explorer shows the trace.dump file created but it is empty.
System Info
Windows 10
Eclipse IDE for C/C++ Developers Version 2019-12(4.14.0) Build id:20191212-1212
FreeROS 10.3.1

Any advice is welcomed.

If you are running from inside eclipse you can start a debug session and step through the code to see what it is doing - the trace dump should only happen if something went wrong. Output should go to the console window inside Eclipse - you may have to explicitly open or at least switch to the console window. Also with mingw the output is not shown until stdout is flushed - but the demo should be set up to do that already.

Thanks a lot for feedback. At least this keeps me moving. While I launched the debug session and stepped into the code, the function vPortGetHeapStats in heap5.c declares a pxBlock pointer and this pointer fetches
pxBlock = xStart.pxNextFreeBlock;
This statement returns NULL. The comment in the file reads that, pxBlock will be NULL if heap is not initialised. I think this could be the source of the problem.

I carried out the same experiment on a different computer that I have access to but I got similar results. This time computer has Windows 7 on it. The FreeRTOS when installed the folder created is FreeRTOSv10.2.1_191129. This computer has a 4GB RAM while the computer used in the first post has a 8GB RAM. Can someone give some more suggestions?

Many thanks in advance.

Two things:

  1. The assert() you experienced is an obsolete test that should be removed. Delete this line (that will mean you can delete the line above and the variables it is using too - but they will be harmless if you remove the assert). Sorry about that.

  2. The console output is working for me - see the image below. You need to wait a few seconds before you see anything.

@rtel Thanks a lot. That worked. I can play around more now.