Different SAM7x hardware

nobody wrote on Thursday, December 07, 2006:

I’m trying to use your FreeRTOS DEMO on my special SAM7X
board, and I have a question about it, so I hope you will able to
answer and help me.
Now I’m using your lwIP Rowley demo with gcc toolchain, I can build the
full project and then download the binary file my board, with Atmel ISP.
But my ethernet connection don’t works. Earlier I used your uIP
FreeRTOS demo in Embedded Workbench, and it worked properly. I
saw that the EMAC Init function is same in the two demo. My board is a
little different from the Atmel’s SAM7X board, so I have to modifie the
EMAC Init function, but I did it before, and it worked with the uIP demo.
So my question is: are there any differences in the demos hardware
layer what I didn’t notice?
Thank you for your reply; and of course sorry for my English:D

rtel wrote on Thursday, December 07, 2006:

The two demos (IAR and Rowley/GCC) were performed on the same hardware, so there are no differences.

lwIP uses a lot more RAM than uIP, also GCC can (depending on the configuration) use more than IAR.  The most likely problem would be a RAM/Stack/Buffer issue.  Do you have access to a debugger?


nobody wrote on Sunday, December 10, 2006:


Thank you for reply.
Sorry I couldn’t answer before. Yes, I have an OCD, but I didn’t use it. I used the demo LED test ability. I toggle different LEDs, different point in the code. I can call the xEMACInit function, but it returns NULL. When I checked it, I saw that the problem is in the xGetLinkSpeed function, because it returns pdFAIL - no link. In uip demo it is not return pdFAIL. So that’s why I thought, in the two demos are two different ways to hardware handling. If there are not different hardware handling, it is weird…