Demo wont compile - Simplicity Studio Giant Gecko

nhepworth wrote on Sunday, June 18, 2017:

I’ve downloaded FreeRTOS version 9.0.0 and imported the demo ‘CORTEX_EFM32_Giant_Gecko_Simplicity_Studio’ supplied into Simplicity Studio v4 as instructed but no matter what I do it wont compile and I’ve tried it with and without the development board STK3700 connected. The compiler gives the following info when I ask for details of the problems …

Errors occurred during the build.
Errors running builder ‘CDT Builder’ on project ‘RTOSDemo’.
failed to generate linker script
PartManager: no entity compatible with
failed to generate linker script
PartManager: no entity compatible with

Can anyone help?

rtel wrote on Sunday, June 18, 2017:

The errors make it sound like Simplicity Studio doesn’t recognise the
part. Are you using the latest Simplicity Studio version with all the
latest part support?

nhepworth wrote on Tuesday, June 20, 2017:

I’ve re-installed Simplicity Studio and checked for updates and am pretty sure its upto date - I can compile other programs for the part and sdk without any problems.

rtel wrote on Wednesday, June 21, 2017:

I can’t check it now as Simplicity Studio is installed on my other
computer, but I was using the project recently.

nhepworth wrote on Wednesday, June 21, 2017:

can you recommend anything I could try - as far as I can see I’m installing the demo on a new installation of Simplicity Studio v4 with their development board

nhepworth wrote on Sunday, June 25, 2017:

It turned out to be Simplicity Studio after all as you originally thought - after the re-install I found that my original programs weren’t working correctly and after hours trying to work out what was wrong I ended up wiping it completely and installing it again. Your demo program is on Simplicity Studio’s list of example programs and this is working fine!

mrchr wrote on Monday, December 11, 2017:

Hi. I get the same errors as Nigel initially got and I’m unable to get around it.
I’ve tested on both macOS and Ubuntu 16.04, any suggestions?
Easiest to give the details for the Ubuntu.

  • Fresh installation of Ubuntu 16.04
  • Fresh installation of Simplicity Studio V4, using latest SDK etc
  • I have installed support in Simplicity Studio for both STK3700 and SLSTK3401A
  • I can compile my regular project (from Simplicity Studio)
  • I can create/build the Simplicity Studio FreeRTOS demos (blink-LED) for both STK3700 and SLSTK3401A
  • I have not connected the HW to the computer (I don’t have the HW and I intend to port to a BGM121)
  • I’ve checkout out the FreeRTOS from ‘trunk’ using SVN.
  • The “Project explorer” has correct paths for the FreeRTOS source


  • If the HW must be connected when importing the Demo, it’d be good to say this on the demo page:
  • I think the problem occurs during the “Import project”, i.e. before trying to build. E.g. the “Include” -paths in the tree listing under the “Project explorer” seem incorrect and show just “/CMISS/Include” instead of e.g. /opt/…/gecko_sdk_suite/v2.0/platform/CMISS/Include

So any thoughts on how to troubleshoot this further? The problem might well be in Simplicity Studio, but on Ubuntu it’s a recent installation and it’d be nice if the if the FreeRTOS demos worked out of the box.