Cynal 8051 port

nobody wrote on Monday, November 08, 2004:

Is the demo program for the Cynal F120 directly compatible with the F124? When I run the program nothing really seems to happen. I have placed break points in the tasks, but the program never seems to reach them. Some of the tasks are not created due to "errCOULD_NOT_ALLOCATE_REQUIRED_MEMORY";
when I just create the "vErrorChecks" and "vRegisterCheck" tasks by themselves, the latter runs OK but the former runs intermitently. Is there something different I should do to make the demo run on the F124? Everything compiles OK and I am using the compilier suggested…

rtel wrote on Tuesday, November 09, 2004:

I have never used the F124, but having just had a look on the Cygnal WEB site there does not seem to be much difference to the F120.

A couple of days ago I tried the latest snapshot of the compiler and this seemed to be fine also.

Are you using the reenterant libraries?  These are available prebuilt from the FreeRTOS WEB if you require them.  Without these (the default when you download the compiler) the scheduler will not operate correctly as the stack usage is completely different.