Connecting STR9 with lwIP demo to internet

anisba wrote on Wednesday, June 11, 2008:


Please I’m trying to connect an STR9 board runing the lwIP FreeRtos Demo to internet.
For this I’m using a Linksys Gateway which I have configured to forward incoming packet from internet to the board.
I used a dynamic DNS ( in order to have a hostname (
Finally I have configured the gateway address on LwIP to be my Gateway lan address.

Locally I’m able to download the page when typing the page URL on my explorer but from outside this doesn’t seem to work.

Do you know if there is any limitation in the http server provided with the demo? or is it performance issue with the STR9?

Or do I need to change anything in the LwiP options.


davedoors wrote on Wednesday, June 11, 2008:

There are a number of things it could be.

Which port number are you using? If using the standard port 80 then check your ISP allows you to run servers. It might block port 80 access. If you are using a non standard port then check your firewall and router don’t block access to non standard ports.

Whatever the problem is it is a networking issue, maybe in the configuration. If you can connect locally then its just a matter of hitting the right setup to be able to connect from externally.

anisba wrote on Wednesday, June 11, 2008:

Hi Dave,

Thanks for your answer.

As you mentionned it my ISP is blocking port 80, so I’ve used port 7777. In fact I’ve configured my gateway to forward any traffic with port 7777 to my STR9 board and with changing port to 80.

I’ve already tested that it works fine using an Apache webserver runing on ubuntu PC (it can be accessed from outside).


rtel wrote on Wednesday, June 11, 2008:

This is how I run the multiple servers I have in my office, different (external) WAN ports are re-directed to port 80 of various IP addresses on my LAN and it works ok.

Did you switch the Ubuntu PC off before you tried?


anisba wrote on Wednesday, June 11, 2008:

Hi Richard,

I was running a windows session during my tests. Also in my gateway I have enabled only one forward to the STR9 board.


anisba wrote on Thursday, June 12, 2008:

Hi Guys,

Just I wanted to mention that I tried the STR9 uIP demo instead of the lwIP, and good news it worked!

Now the website can be accessed from internet. I need to investigate why it didn’t work with lwIp demo.

Thanks for your help,