configTICK_RATE_HZ

nobody wrote on Sunday, March 26, 2006:

I am using STR71X port. configTICK_RATE_HZ=1000.
Is it too high? When I set configTICK_RATE_HZ=100
The kernel can’t work. Lowering this value will improve efficiency,I think.But i don’t know how much configTICK_RATE_HZ is.

rtel wrote on Sunday, March 26, 2006:

The tick interrupt is configured using the library provided by ST.  See the function prvSetupTimerInterrupt() in port.c.  The existing code I think uses the library incorrectly.  Unfortunately this is also the case in V4.0.0 to be released tomorrow.  This is the only "known issue" in V4.0.0 and will be on the issue list tomorrow.

Take a look at the function, as it uses the library it should be simply to fix (I hope), unless the library itself is incorrect.

I have seen 1000Hz works ok, but 100Hz, not so can confirm your results.  Sorry for inconvenience! 

nobody wrote on Monday, March 27, 2006:

Thank you for help!
V4.0.0 to will be released ? Oh! very good!
I am waiting the new version for a long time!

nobody wrote on Tuesday, March 28, 2006:

Well the libary function works fine, but the function WDG_PeriodValueConfig the input parameter is time in uS, not Hz, so in order to get 100 Hz you can set the tick rate to 10000.

Or change the line to:

WDG_PeriodValueConfig((1/configTICK_RATE)*1000);

Best regards,

Frank Andersen

nobody wrote on Thursday, March 30, 2006:

Oh I see!
Thanks!