Cellular Interface ctest option file contents

I am attempting to run ctest for the Cellular Interface as I have added a new modem module. It says there was no test configuration file found and each test is ‘Not Run’ due to this. I tried to find info on what is supposed to be in the option file to trigger the tests to run. Can someone please outline how to run these tests? Fairly new to FreeRTOS and have not used Cmock before.

Hi @tstaz,
Welcome to FreeRTOS community!

You can follow Build Unit Test to execute existing ctest test cases in cellular interface. Those test cases are stored in unit-test folder. And you can refer to CMakeList.txt and create_test.cmake to know how we add test cases into ctest framework.

Thank you.

Here is what I get when I run the tests:

PS C:\Projects\1289_VB_Cal\SW\reference\FreeRtos\FreeRTOS\FreeRTOS-Plus\Source\FreeRTOS-Cellular-Interface\build> ctest
Test project C:/Projects/1289_VB_Cal/SW/reference/FreeRtos/FreeRTOS/FreeRTOS-Plus/Source/FreeRTOS-Cellular-Interface/build
Start 1: cellular_pkthandler_utest
Test not available without configuration. (Missing “-C ”?)
1/7 Test #1: cellular_pkthandler_utest …***Not Run 0.00 sec
Start 2: cellular_common_api_utest
Test not available without configuration. (Missing “-C ”?)
2/7 Test #2: cellular_common_api_utest …***Not Run 0.00 sec
Start 3: cellular_3gpp_api_utest
Test not available without configuration. (Missing “-C ”?)
3/7 Test #3: cellular_3gpp_api_utest …***Not Run 0.00 sec
Start 4: cellular_3gpp_urc_handler_utest
Test not available without configuration. (Missing “-C ”?)
4/7 Test #4: cellular_3gpp_urc_handler_utest …***Not Run 0.00 sec
Start 5: cellular_at_core_utest
Test not available without configuration. (Missing “-C ”?)
5/7 Test #5: cellular_at_core_utest …***Not Run 0.00 sec
Start 6: cellular_pktio_utest
Test not available without configuration. (Missing “-C ”?)
6/7 Test #6: cellular_pktio_utest …***Not Run 0.00 sec
Start 7: cellular_common_utest
Test not available without configuration. (Missing “-C ”?)
7/7 Test #7: cellular_common_utest …***Not Run 0.00 sec

0% tests passed, 7 tests failed out of 7

Total Test time (real) = 0.01 sec

The following tests FAILED:
1 - cellular_pkthandler_utest (Not Run)
2 - cellular_common_api_utest (Not Run)
3 - cellular_3gpp_api_utest (Not Run)
4 - cellular_3gpp_urc_handler_utest (Not Run)
5 - cellular_at_core_utest (Not Run)
6 - cellular_pktio_utest (Not Run)
7 - cellular_common_utest (Not Run)
Errors while running CTest

It appears I need a test configuration file to enable all tests?


Hi @tstaz,
Seems like you’re running test cases on Windows. Could you help try to run it on Linux (e.g. WSL)?

Thank you.