Bringing up FreeRTOS on Beaglebone black platform(AM355x)

sandeepmn46 wrote on Friday, November 17, 2017:


I am trying to bring up my Beaglebone black(AM335x) platform with FreeRTOS OS (FreeRTOS 7.1 or higher versions).
I want to boot from a SD Card (4 GB). Since I don’t have any previous experience in working with Beaglebone black, I referred the below github for getting the binaries and creating a SD card bootable with FreeRTOS.

I referred the below links for bringing up the SD card making it bootable and trying to boot from SD Card.'s_Guide

I have downloaded RTOS-SDK for beagle bone black from the below link. “ti-processor-sdk-rtos-am335x-evm-”
After installing the above SDK in Ubuntu 14-04 (64 bit) I tried making the SD card bootable using ‘’ script.

Using the script and SDCard files (MLO, rtosdemo-a.bin, u-boot.img, uEnv,txt), made the SD Card as bootable and tried booting BBB from that.
Getting the below error:

U-Boot SPL 2014.04-00014-g8732558 (Apr 18 2014 - 14:53:44)
** Partition 1 not valid on device 0 **
spl_register_fat_device: fat register err - -1

ERROR ### Please RESET the board


How can I resolve this issue and get a successful boot.?

Please advice me in the below things:

1- Whether I can get the procedure for bringing up the SD Card with FreeRTOS and booting the BBB from it.

2- Which all files are required for making the SD Card bootable.

Thanks in advance

rtel wrote on Friday, November 17, 2017:

Sorry - I don’t know anything about using a BBB. I would recommend
asking whoever created and provided the port and instructions.