ARM7_AT91FR40008 - cannot compile

olebon wrote on Thursday, July 08, 2010:

I’ve installed GNUARM and UNXUtils exactly as it is described on the demo web page, but when I run any batch file on my Vista machine the output is the same:



C:\FreeRTOS\Demo\ARM7_AT91FR40008_GCC>set DEBUG=-g

C:\FreeRTOS\Demo\ARM7_AT91FR40008_GCC>set OPTIM=-O0


C:\FreeRTOS\Demo\ARM7_AT91FR40008_GCC>set LDSCRIPT=atmel-ram.ld

C:\FreeRTOS\Demo\ARM7_AT91FR40008_GCC>make arm-elf-gcc -c -Wall -Wextra -D RUN_FROM_RAM -D GCC_AT91FR40008 -I. -I…/…/Source/include -I…/Common/include -g -mcpu=arm7tdmi -Tatmel-ram.ld -Wcast-align -O0
-fomit-frame-pointer -fno-strict-aliasing -fno-dwarf2-cfi-asm -mthumb-interwork
-D THUMB_INTERWORK …/…/Source/portable/GCC/ARM7_AT91FR40008/portISR.c -o …/…/Source/portable/GCC/ARM7_AT91FR40008/portISR.o
process_begin: CreateProcess((null), arm-elf-gcc -c -Wall -Wextra -D RUN_FROM_RAM -D GCC_AT91FR40008 -I. -I…/…/Source/include -I…/Common/include -g -mcpu=arm
7tdmi -Tatmel-ram.ld -Wcast-align -O0 -fomit-frame-pointer -fno-strict-aliasing-fno-dwarf2-cfi-asm -mthumb-interwork -D THUMB_INTERWORK …/…/Source/portable/G
CC/ARM7_AT91FR40008/portISR.c -o …/…/Source/portable/GCC/ARM7_AT91FR40008/portISR.o, …) failed.
make (e=2): The system cannot find the file specified.
make: ***  Error 2

Is there a way fix it? Thanks!

davedoors wrote on Wednesday, July 14, 2010:

I just tried ROM_THUMB.bat with Yagarto and it built without any warnings at all.