ARM-7 Tasks executing in System Mode

dcgirish16 wrote on Wednesday, August 13, 2014:

Any reason that the tasks FreeRTOS are executed in ‘system’ mode instead of user mode? Tried searching for this kind of topic but could not find a convincing one… I apologize if this question is repeated… In case I don’t want to give a task permission to disable/enable interrupts, then the task should obviously run in User mode.


davedoors wrote on Wednesday, August 13, 2014:

FreeRTOS for ARM7 always runs tasks in System mode. These ports are really old. FreeRTOS for Cortex has two ports, the first runs all tasks in System mode like the ARM7 port, the second called FreeRTOS MPU can have tasks in privileged or unprivileged mode. I don’t think many people use the MPU version though. I don’t know how maintained it is.