Amazon FreeRTOS / PIC32MZ / Wifi 7 Click Board --> Issue DHCP timeout

leandropg wrote on July 04, 2019:

Currently, I am working with Amazon FreeRTOS, PIC32MZ and Wifi 7 Click Board. When I am connecting the PIC32 to internet through Normal Access Point (Router) via Wifi this works fine. I have reviewed in the log files, the protocol exchange of the DHCP server and works fine. The 4 stages of the protocol works fine (Discover / Offer / Request / Acknowledgement).

https://upload.wikimedia.org/wikipedia/commons/2/28/DHCP_session_en.svg

But, when I connect to internet through Hotspot Wifi or and Wifi Repetear the protocol was stuck in the Request stage, never arrive the Acknowledgement command. I have review in my Wifi Repeater and the DHCP is controller by the router not by the repeater itself.

I don’t understand the problem. My current AWS FreeRTOS version is 1.4.7. I have updated the code DHCP Server to version 1.4.9, but the problem persist.

I have looking for how update the firmware in the ATWINC1510-MR210PB by possible firmware issues, but it is not easy understand the process, so I need at Atmel SAM 21D for this task :frowning:

https://www.microchip.com/wwwproducts/en/ATwinc1500

Additionally, I don’t understand how the code use the driver WILC1000, but the hardware is ATWINC1510. I don’t understand why reason the code show the version Firmware ver: 4.2.3 but the last firmware is 19.5.4

I appreciate all your help. Thanks.

SarenaAtAws wrote on July 06, 2019:

Hello leandropg,

I am able to connect both directly to my router Wi-Fi access point and to my Wi-Fi hotspot with the latest version of Amazon FreeRTOS: https://github.com/aws/amazon-freertos/tree/201906.00_Major.

Using version 1.4.7 (https://github.com/aws/amazon-freertos/tree/v1.4.7) I can do the same.

Here is part of my output for the former version:


Bootloader version 00.09.00
[prvBOOT_Init] Watchdog timer initialized.
[prvBOOT_Init] Crypto initialized.

[prvValidateImage] Validating image at Bank : 0
[prvValidateImage] No application image or magic code present at: 0xbd000000
[prvBOOT_ValidateImages] Validation failed for image at 0xbd000000

[prvValidateImage] Validating image at Bank : 1
[prvValidateImage] No application image or magic code present at: 0xbd100000
[prvBOOT_ValidateImages] Validation failed for image at 0xbd100000

[prvBOOT_ValidateImages] Booting default image.
WILC1000: Initializing...



Firmware ver     : 4.2.3
Min driver ver : 4.2.3
Curr driver ver: 4.2.3
Start Wi-Fi Connection...
Wi-Fi Connected
0 2042 [IP-task] vDHCPProcess: offer c0a8019bip
WILC1000: De-initializing...
1 2063 [IP-task] vDHCPProcess: offer c0a8019bip
2 2063 [IP-task] Write certificate...
3 2066 [IP-task] Write dWILC1000: Initializing...
evice private key...
4 2113 [IP-task]

IP Address: 192.168.1.155
5 2113 [IP-task] Subnet Mask: 255.255.255.0
6 2113 [IP-task] Gateway Address: 192.168.1.1
7 2113 [IP-task] DNS Server Address: 192.168.1.1


8 2114 [iot_thread] [INFO ][INIT][2114] SDK successfully initialized.
Chip ID 1503a0
Firmware ver     : 4.2.3
Min driver ver : 4.2.3
Curr driver ver: 4.2.3
Start Wi-Fi Connection...
Wi-Fi Connected
9 4149 [iot_thread] [INFO ][DEMO][4149] Successfully initialized the demo. Network type for the demo: 1

The router I am using is the Asus RTAC66R. The settings for DHCP are default. Meaning the server is on, lease time is 86400, and manual assignment is off. You can check if these are your settings as well.

The latest version of Amazon FreeRTOS has FreeRTOS+TCP V2.0.11, which has a few DHCP fixes, you find those in the CHANGELOG.md. I would suggest giving that a try.

leandropg wrote on July 22, 2019:

Thank you