Unable to start the freeRTOS project

When executing main.c file inside this folder I am getting 10 messages that files not found.
I check and I found that correct files are getting called with correct paths.
I am unable to upload zip file here nor I can put links here.

You may be hitting the Windows path limit. Please move the code to a shorter path i.e. use something like C:\FreeRTOS_Labs\FreeRTOS-Plus\Demo\FreeRTOS_Plus_TCP_and_FAT_Windows_Simulator instead of


Thanks @aggarg for the suggestion.
It’s working for me now.

It is running but it is now printing out in the terminal that “no network interfaces were found”

See the setup instructions here: Running FreeRTOS+TCP Examples in the RTOS Simulator


My computer configurations are:
Subnet Mask
Default Gateway

Configurations for RTOS environment
ipconfigUSE_DHCP 0

configIP_ADDR0 192
configIP_ADDR1 168
configIP_ADDR2 1
configIP_ADDR3 20

configNET_MASK0 255
configNET_MASK1 255
configNET_MASK2 255
configNET_MASK3 0

Even if I set ipconfigUSE_DHCP 1 or ipconfigUSE_DHCP 0
I am getting the same message :
“No Network interface were found”
“attempting to open interface 2”
configNETWORK_INTERFACE_TO_USE is not in valid range

configNETWORK_INTERFACE_TO_USE does not seem to be set correctly. What is its value in your FreeRTOSConfig.h? Can you paste the complete output?

This call should print all the available network interfaces: FreeRTOS-Plus-TCP/NetworkInterface.c at main · FreeRTOS/FreeRTOS-Plus-TCP · GitHub

Please paste the complete output.


By default it was set to 4L
But I tried 0,1,2,3,4 for testing.
Complete output:
0 0 [None] Seed for randomiser: 1622621821
1 0 [None] Random numbers: 00007907 00001135 0000691C 00004FEC
2 0 [None] FreeRTOS_IPInit
3 0 [None] vAssertCalled( A:\Personal Projects\IoT Aircraft Runway Project\templateCode\FreeRTOS_v9.0.1\160919_FreeRTOS_Labs\FreeRTOS-Plus\Source\FreeRTOS-Plus-TCP\FreeRTOS_IP.c, 1030

So I was testing with different configurations here and there.
I made a dummy connection with raspberry pi using ethernet cable.
I made the gateway address in FreeRTOSConfig.h same as my wifi default gateway.
Then I set configNETWORK_INTERFACE_TO_USE 2 and somehow it worked.
Earlier it was showing no interface found with much of the same values.

Thanks @aggarg for the help and suggestions.