Problem while build the NIOS II Cyclone III Demo

I have downloaded the “” and tried to run the demo of NiosII_CycloneIII_DBC3C40_GCC by following the steps given in the “”.

However, after importing to this into the NIOS II Eclipse IDE, when I select the “Build All” option, nothing is happening. Why this type of problem is arising?.
Any project setting is required to do it?.

I suspect this is because the format of the Eclipse project file in the download is too old for the version of the IDE you are using. Have you looked at the project settings (right click the project in the project explorer, click properties, then C/C++ Build, then settings too see).

Hello, @rtel I had the same doubt hence, I already tried with modifying some project settings like PATH variable, Toolchain selection but none of my changed settings are not worked.
I attached one zip file which consists of the default C/C++ build setting of the IDE.
Can you guide me to resolve this issue?. C_C (407.0 KB) Which settings are wrong and need to modify?.

1 Like

Hello AP_040
did you find any solution i’m also facing the same problem.
Thank you

Hello @asiddiqui
I tried various ways as per my thinking but not found proper way to do this.
Yet not found the any solution.

Hello AP_040
I tried with Max10
it’s working for me.
from here you can find steps:

Thank you

Thank you so much @asiddiqui…!! I will try your suggested steps once I have time to test it. I am little bit busy with other task. If facing any issue during the test step as you have performed, I will get back to you.

1 Like

Hello @asiddiqui,
I tried with your suggested steps and getting error which is attached

Can you help with it?.

Hello AP_040
I have no idea why it’s giving this error, i got the error but that was memory problem, then i switch to SDRAM from onchip memory and problem was solved