MQTT mutual auth demo "Failed to perform TLS handshake"

I’ve achieved communication with the AWS MQTT broker. It was pretty straight forward. OK, now to port to the nRF9160DK board.

Glad that it worked for you.

I had this same error trying to connect to a Mosquitto broker:
[ERROR][NET] (Network connection 1fff9c60) Failed to perform SSL handshake. error: X509 - Certificate verification failed, e.g. CRL, CA or signature check failed.
using the AWS IoT Demo of the AWS IoT Client in a Cortex M4. I use Keil with the MDK Network interface (not Freertos TCP).
In this case I solved it by setting true the disableSni in the IotNetworkCredentials struct:

credentials.disableSni = true;

I will try also to make all the certificates with different names, but this make the trick by now.

Thanks!

Edit: seems that don’t work changing the “Organization Name” of each certificate, disableSni will be used until a clearer resolution of this error.

Thank you for taking time to report back.