FreeRTOS+TCP NetworkInterface for STM32F7xx - hard fault after ethernet mac interrupt callback

Congratulations, GSF.

Does ping also work?

though network buffer is depleted very fast

Where do you read this? In “Network buffers: 52 lowest 52” ? Looks like it’s leaking…

In case you opened an UDP socket, you might loose Network Buffers in case you forget to call FreeRTOS_recv(). This risk can be limited by defining ipconfigUDP_MAX_RX_PACKETS. But of course you must call FreeRTOS_recv()to unload the buffers.

Your logging looks strange because most strings are ended with a linefeed only. In puTTY I normally use the Terminal option: “Implicit CR in every LF”.

Hi Hein,

I’m using picocom on ubuntu, I will check whether can configure it to work more neat :slight_smile:

I’m using an aws_tests project from other platform. so it’s mqtt over secure sockets(tcp). I will go deeper later on. the network descriptor is 60 and I remember well the “lowest 52” is the highest water mark of free available descriptors.

from the log most of the time it’s in idle task(and emac task log showed the network buffer drop quickly), when I stop debug it may enter into network up callback to log the network settings(print ip/gateway etc.).

Hi Hein,

sorry to disturb you again. I find the network is not working, no matter use static address or DHCP.

here is the screenshot of my router, the board is not connected:

the console log is switch between emac task and idle task:

attached the debugger, I find it’s stuck on vDHCPProcess():

in eWaitingOffer state,

prvProcessDHCPReplies( dhcpMESSAGE_TYPE_OFFER ) == pdPASS )

is false, so prvSendDHCPDiscover( ) again, till ipconfigMAXIMUM_DISCOVER_TX_PERIOD reached and xGivingUp = pdTrue then use static address(also not working):

any suggestions to check further ? seems the tcp/ip stack is not talking with network interface yet.


Maybe it is time that we connect directly, so we can share projects and exchange information more quickly?

We will report back here how things went.

This is my email address: hein [at] htibosch [dot] net.